US1 (portal.clumio.com) Stuck backups due to degraded performance

Incident Report for Clumio

Resolved

This incident has been resolved.
Posted Aug 02, 2025 - 16:11 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 02, 2025 - 01:22 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 01, 2025 - 21:57 UTC

Investigating

We are currently investigating the issue.

Customer Impact : Microsoft 365 backups are in a queued state and not completing in the platform
Posted Aug 01, 2025 - 20:02 UTC
This incident affected: US1 (https://portal.clumio.com) (M365 Exchange, M365 OneDrive, M365 SharePoint) and US2 (https://us2.portal.clumio.com) (M365 Exchange, M365 OneDrive, M365 SharePoint).