We are still in the process of recovering from the recent issue and are working diligently to stabilize services and ensure operations are fully restored.
Posted Jun 06, 2025 - 21:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2025 - 17:53 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 06, 2025 - 16:38 UTC
Update
The issue has been identified, and we are currently working on a fix.
Posted Jun 06, 2025 - 12:41 UTC
Investigating
We are currently investigating this issue.
Posted Jun 06, 2025 - 12:00 UTC
This incident affected: US1 (https://portal.clumio.com) (AWS EC2, AWS EBS, AWS S3, AWS RDS, AWS DynamoDB, AWS MS SQL on EC2, M365 Exchange, M365 OneDrive, M365 SharePoint).